vagrant with nokogiri

2014/8/10 1811hit

OSをMervericksに上げるとruby周りが色々ぶっ壊れました。。。

vagrantが上がらないようになったのが痛い
一回アンインストールして、プラグインを入れ直そうと思ったらvagrantが使うnokogiriでエラー


Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing nokogiri (1.6.3.1), and Bundler cannot continue.
Make sure that `gem install nokogiri -v '1.6.3.1'` succeeds before bundling.


以下で解決


brew install libxml2 && brew link libxml2 --force
cd $HOME/.vagrant.d/gems/
/Applications/Vagrant/embedded/bin/gem install --install-dir ~/.vagrant.d/gems nokogiri -v ‘1.6.3.1’ -- --use-system-libraries --with-xml2-include=/usr/local/Cellar/libxml2/2.9.1/include/libxml2
vagrant plugin install vagrant-berkshelf --plugin-version '>=2.0.1'


libxmlが古いで一回怒られたけどなんとかfix

前:ParseのAndroidでCheckManifestエラー 次:go && vim

関連キーワード

[IT]

コメントを投稿する

名前URI
コメント